Commercial Credit service issues - 04/11/2026 11:30 EST

Incident Report for Shared Services

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 18:03 EDT

Identified

The Reusify team discovered an issue with the Commercial Credit service. Our vendor, Experian, has shared the following details:

Incident Start Time: 11:30 EST
Incident End Time: TBD

Issue details:
Our technical teams are investigating an issue affecting Business Credit. As soon as we have identified the issue, we will send out communications via Experian incident notification system.

Customer Experience: Clients may notice a delay or no response in accessing Business Credit.

Reusify customers might experience slowness or no response when making commercial credit calls. We will provide updates as we receive further communication from our vendor.
Posted Apr 17, 2026 - 15:26 EDT
This incident affected: Reusify - Compliance & Credit (Commercial Credit).