Attract Score - Potential service issues detected at 11:17 UTC

Incident Report for Shared Services

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 11:52 EST

Investigating

The reusify team is currently investigating a potential issue with the Attract Score service. If we determine there is one, we will update this status page incident with further details. Please reach out to our team if you are experiencing any issues.
Posted Feb 15, 2026 - 06:17 EST
This incident affected: Reusify - Vehicle & Driver (Attract Score).