LexisNexis - Motor Vehicle Report - TestComponent - Issues Detected at 13:24 UTC

Incident Report for Shared Services

Resolved

MISSISSIPPI interactive MVR processing is now available. Product: Interactive MVR Status: Available Reason: State Issue
Posted Aug 18, 2026 - 09:26 EDT

Investigating

MISSISSIPPI is currently experiencing a service interruption affecting their interactive MVR processing. Product: Interactive MVR Status: Unavailable Reason: State Issue Estimated Time of Response: No ETR
Posted Aug 18, 2026 - 09:24 EDT
This incident affected: TESTING (Motor Vehicle Report - TestComponent).