Reusify - Geospatial Parcel Lookup Service Issues June 12,2026, 11 PM EST

Incident Report for Shared Services

Resolved

This incident has been resolved.
Posted Jun 13, 2026 - 02:54 EDT

Monitoring

The Reusify team has discovered an issue with the Geospatial Parcel Lookup/ Ecopia service.

Incident number: INC02327809
Start time:
06/12/2026, 11 PM EST

Customers may experience degraded response when accessing the service. Our team is actively investigating the issue and working to restore normal operations. We will provide updates as more information becomes available.
Posted Jun 13, 2026 - 01:28 EDT
This incident affected: Reusify - Geospatial (Geospatial Parcel Lookup).