RHODE ISLAND Motor Vehicle Reports service issues February 17, 2026, 10:20 PM EST.

Incident Report for Shared Services

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 05:34 EST

Monitoring

The Reusify team has discovered an issue with the Motor Vehicle Reports service for RHODE ISLAND.

Issue details:
The following information has been provided by LexisNexis:

Dear Valued Customer,
RHODE ISLAND is currently experiencing a service interruption affecting their interactive MVR processing.
Product: Interactive MVR
Status: Unavailable
Reason: State Issue
Estimated Time of Response: No ETR

If you have any questions, please contact System to System Production Support at s2sproduction@lexisnexisrisk.com or call 800-236-9993.


Incident start time:
February 17, 2026, 10:20 PM EST.

We are currently monitoring this issue and will update as soon as we have more information.
Posted Feb 17, 2026 - 22:34 EST
This incident affected: Reusify - Vehicle & Driver (Motor Vehicle Reports).